<!DOCTYPE HTML>

<html lang="en-US"
 xmlns:fb="http://ogp.me/ns/fb#"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Class of 1983: "Videodrome" | THE FILM YAP</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="http://www.thefilmyap.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="http://www.thefilmyap.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="http://www.thefilmyap.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="http://www.thefilmyap.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="http://www.thefilmyap.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="/favicon.ico" />
    
    <link href="http://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside4.jpg" />    
    	
	<link rel="pingback" href="http://www.thefilmyap.com/xmlrpc.php" />

	    
     
    
	
<!-- All in One SEO Pack 2.3.11.1 by Michael Torbert of Semper Fi Web Design[328,389] -->
<meta name="description"  content="&quot;Videodrome&quot; shows how David Cronenberg is sometimes a provocateur only to a point. But he also wasn't far from his cinematic incisions that cut the deepest." />

<meta name="keywords"  content="videodrome,class of 1983,nick rogers,film criticism,1983,david cronenberg,james woods,debbie harry,media,television,violence,sex,videotape,tv,canada,snuff film,conspiracy,parable,max renn,michael lennick,frank c. carere,rick baker,horror,cult,science fiction" />

<link rel="canonical" href="http://www.thefilmyap.com/movies/class-of-1983-videodrome/" />
<meta property="og:title" content="Class of 1983: &quot;Videodrome&quot; | THE FILM YAP" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.thefilmyap.com/movies/class-of-1983-videodrome/" />
<meta property="og:image" content="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside4.jpg" />
<meta property="og:image:width" content="630" />
<meta property="og:image:height" content="315" />
<meta property="og:site_name" content="THE FILM YAP" />
<meta property="og:description" content="&quot;Videodrome&quot; shows how David Cronenberg is sometimes a provocateur only to a point. But he also wasn&#039;t far from his cinematic incisions that cut the deepest." />
<meta property="article:published_time" content="2013-02-28T00:01:47Z" />
<meta property="article:modified_time" content="2015-06-29T17:28:45Z" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@TheFilmYap" />
<meta name="twitter:domain" content="www.thefilmyap.com" />
<meta name="twitter:title" content="Class of 1983: &quot;Videodrome&quot; | THE FILM YAP" />
<meta name="twitter:description" content="&quot;Videodrome&quot; shows how David Cronenberg is sometimes a provocateur only to a point. But he also wasn&#039;t far from his cinematic incisions that cut the deepest." />
<meta name="twitter:image" content="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside4.jpg" />
<meta itemprop="image" content="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside4.jpg" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="THE FILM YAP &raquo; Feed" href="http://www.thefilmyap.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="THE FILM YAP &raquo; Comments Feed" href="http://www.thefilmyap.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="THE FILM YAP &raquo; Class of 1983: &#8220;Videodrome&#8221; Comments Feed" href="http://www.thefilmyap.com/movies/class-of-1983-videodrome/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.thefilmyap.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='validate-engine-css-css'  href='http://www.thefilmyap.com/wp-content/plugins/wysija-newsletters/css/validationEngine.jquery.css?ver=2.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.thefilmyap.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://www.thefilmyap.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.thefilmyap.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.thefilmyap.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='The Master' href='http://www.thefilmyap.com/movies/the-master/' />
<link rel='next' title='21 &#038; Over' href='http://www.thefilmyap.com/movies/21-over/' />
<meta name="generator" content="WordPress 4.7.2" />
<link rel='shortlink' href='http://wp.me/p2O9DN-9ZY' />
<link rel="alternate" type="application/json+oembed" href="http://www.thefilmyap.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.thefilmyap.com%2Fmovies%2Fclass-of-1983-videodrome%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.thefilmyap.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.thefilmyap.com%2Fmovies%2Fclass-of-1983-videodrome%2F&#038;format=xml" />
<meta property="fb:app_id" content="1674882656065160"/>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
	
</head>


<body class="it_movies-template-default single single-it_movies postid-38438 it-background woocommerce">

	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="http://www.thefilmyap.com/" title="Home">
                                        <img id="site-logo" alt="THE FILM YAP" src="http://www.thefilmyap.com/wp-content/uploads/2014/12/thefilmyap-logo-50h.png" width="155" height="50" />   
                                        <img id="site-logo-hd" alt="THE FILM YAP" src="http://www.thefilmyap.com/wp-content/uploads/2014/12/thefilmyap-logo-50h.png" width="155" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <div class="standard-menu"><ul id="menu-section-menu" class="menu"><li id="menu-item-52402" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-52402"><a href="http://www.thefilmyap.com/topics/reviews-2/">Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-52397" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52397"><a href="http://www.thefilmyap.com/topics/reviews-2/movie-reviews/">In Theaters</a></li>
	<li id="menu-item-52398" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52398"><a href="http://www.thefilmyap.com/topics/reviews-2/dvd-reviews/">On DVD</a></li>
	<li id="menu-item-52405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52405"><a href="http://www.thefilmyap.com/topics/reviews-2/couchpotato/">Couch Potato Cinema</a></li>
	<li id="menu-item-52404" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52404"><a href="http://www.thefilmyap.com/topics/reviews-2/schlocky-bs/">The Schlock Vault</a></li>
	<li id="menu-item-52403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52403"><a href="http://www.thefilmyap.com/topics/reviews-2/reeling-backward/">Reeling Backward</a></li>
</ul>
</li>
<li id="menu-item-52406" class="menu-item menu-item-type-taxonomy menu-item-object-category current-it_movies-ancestor menu-item-has-children menu-item-52406"><a href="http://www.thefilmyap.com/topics/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-52409" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52409"><a href="http://www.thefilmyap.com/topics/features/news-features/">News</a></li>
	<li id="menu-item-52408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52408"><a href="http://www.thefilmyap.com/topics/features/interviews/">Interviews</a></li>
	<li id="menu-item-52407" class="menu-item menu-item-type-taxonomy menu-item-object-category current-it_movies-ancestor current-menu-parent current-it_movies-parent menu-item-52407"><a href="http://www.thefilmyap.com/topics/features/commentary/">Commentary</a></li>
	<li id="menu-item-52410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52410"><a href="http://www.thefilmyap.com/topics/features/365/">The 365 Best Films of the 2000s</a></li>
	<li id="menu-item-52411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52411"><a href="http://www.thefilmyap.com/topics/features/52/">The 52 Worst Films of the 2000s</a></li>
</ul>
</li>
<li id="menu-item-52413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-52413"><a href="http://www.thefilmyap.com/topics/festivals/">Festivals</a>
<ul class="sub-menu">
	<li id="menu-item-52414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-52414"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/">Heartland Film Festival</a>
	<ul class="sub-menu">
		<li id="menu-item-52415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52415"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland09/">2009 Heartland Film Festival</a></li>
		<li id="menu-item-52416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52416"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland10/">2010 Heartland Film Festival</a></li>
		<li id="menu-item-52417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52417"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland11/">2011 Heartland Film Festival</a></li>
		<li id="menu-item-52418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52418"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland12/">2012 Heartland Film Festival</a></li>
		<li id="menu-item-52419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52419"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland13/">2013 Heartland Film Festival</a></li>
		<li id="menu-item-52420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52420"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland_film_festival_14/">2014 Heartland Film Festival</a></li>
		<li id="menu-item-57111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57111"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/2015-heartland-film-festival/">2015 Heartland Film Festival</a></li>
		<li id="menu-item-62689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62689"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland16/">2016 Heartland Film Festival</a></li>
	</ul>
</li>
	<li id="menu-item-52421" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-52421"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/">Indy Film Festival</a>
	<ul class="sub-menu">
		<li id="menu-item-52422" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52422"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/iiff09/">2009 Indy Int&#8217;l Film Festival</a></li>
		<li id="menu-item-52423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52423"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/iiff10/">2010 Indy Int&#8217;l Film Festival</a></li>
		<li id="menu-item-52424" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52424"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/iiff11/">2011 Indy Int&#8217;l Film Festival</a></li>
		<li id="menu-item-52425" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52425"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/iiff12/">2012 Indy Int’l Film Festival</a></li>
		<li id="menu-item-52426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52426"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/iiff13/">2013 Indy Int’l Film Festival</a></li>
		<li id="menu-item-52427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52427"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/indyfilmfest/">2014 Indy Film Fest</a></li>
		<li id="menu-item-54666" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54666"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/2015-indy-film-fest/">2015 Indy Film Fest</a></li>
		<li id="menu-item-61226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61226"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/2016-indy-film-festival/">2016 Indy Film Festival</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-52428" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52428"><a href="http://www.thefilmyap.com/topics/av-room/">The AV Room</a></li>
</ul></div>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <div class="standard-menu"><ul id="menu-section-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-52402"><a href="http://www.thefilmyap.com/topics/reviews-2/">Reviews</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52397"><a href="http://www.thefilmyap.com/topics/reviews-2/movie-reviews/">In Theaters</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52398"><a href="http://www.thefilmyap.com/topics/reviews-2/dvd-reviews/">On DVD</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52405"><a href="http://www.thefilmyap.com/topics/reviews-2/couchpotato/">Couch Potato Cinema</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52404"><a href="http://www.thefilmyap.com/topics/reviews-2/schlocky-bs/">The Schlock Vault</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52403"><a href="http://www.thefilmyap.com/topics/reviews-2/reeling-backward/">Reeling Backward</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-it_movies-ancestor menu-item-has-children menu-item-52406"><a href="http://www.thefilmyap.com/topics/features/">Features</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52409"><a href="http://www.thefilmyap.com/topics/features/news-features/">News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52408"><a href="http://www.thefilmyap.com/topics/features/interviews/">Interviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-it_movies-ancestor current-menu-parent current-it_movies-parent menu-item-52407"><a href="http://www.thefilmyap.com/topics/features/commentary/">Commentary</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52410"><a href="http://www.thefilmyap.com/topics/features/365/">The 365 Best Films of the 2000s</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52411"><a href="http://www.thefilmyap.com/topics/features/52/">The 52 Worst Films of the 2000s</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-52413"><a href="http://www.thefilmyap.com/topics/festivals/">Festivals</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-52414"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/">Heartland Film Festival</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52415"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland09/">2009 Heartland Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52416"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland10/">2010 Heartland Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52417"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland11/">2011 Heartland Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52418"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland12/">2012 Heartland Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52419"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland13/">2013 Heartland Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52420"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland_film_festival_14/">2014 Heartland Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57111"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/2015-heartland-film-festival/">2015 Heartland Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62689"><a href="http://www.thefilmyap.com/topics/festivals/heartland-film-festival/heartland16/">2016 Heartland Film Festival</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-52421"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/">Indy Film Festival</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52422"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/iiff09/">2009 Indy Int&#8217;l Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52423"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/iiff10/">2010 Indy Int&#8217;l Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52424"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/iiff11/">2011 Indy Int&#8217;l Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52425"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/iiff12/">2012 Indy Int’l Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52426"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/iiff13/">2013 Indy Int’l Film Festival</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52427"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/indyfilmfest/">2014 Indy Film Fest</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54666"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/2015-indy-film-fest/">2015 Indy Film Fest</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61226"><a href="http://www.thefilmyap.com/topics/festivals/indy-film-festival/2016-indy-film-festival/">2016 Indy Film Festival</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52428"><a href="http://www.thefilmyap.com/topics/av-room/">The AV Room</a></li>
</ul></div>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                                    
                            <a id="random-article" href="http://www.thefilmyap.com/movies/i-eat-your-skin-1964/" class="info-bottom icon-random" title="Random Article"></a>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="http://www.thefilmyap.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="http://www.thefilmyap.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/movies/class-of-1983-videodrome/comment-page-1/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="http://www.thefilmyap.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/movies/class-of-1983-videodrome/comment-page-1/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="http://www.thefilmyap.com/">
                        <img id="site-logo" alt="THE FILM YAP" src="http://www.thefilmyap.com/wp-content/uploads/2014/12/thefilmyap-logo-50h.png" width="155" height="50" />   
                        <img id="site-logo-hd" alt="THE FILM YAP" src="http://www.thefilmyap.com/wp-content/uploads/2014/12/thefilmyap-logo-50h.png" width="155" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        




<div class="container">

    <div id="content-wrapper" class="single-page minisite-page full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="http://www.thefilmyap.com/movies/the-master/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">The Master</div>&nbsp;</div></div><div class="random-wrapper"><a href="http://www.thefilmyap.com/movies/the-wolf-of-wall-street-2013/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="http://www.thefilmyap.com/movies/21-over/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">21 & Over</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                    
                                                <div class="minisite-wrapper">movies</div>                                                
                                                                                        
                                                                                        
                                                <div class="award-grid"></div>                                                
                                                                                    
                                                                                
                                        <span class="metric" title="Views"><span class="icon icon-viewed"></span><span class="numcount">707 views</span></span>                                        
                                        <a class="like-button do-like 38438" data-postid="38438" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">0 likes</span></a>                                        
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">3 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-38438" class="post-38438 it_movies type-it_movies status-publish has-post-thumbnail hentry category-commentary tag-7093 tag-canada tag-class-of-1983 tag-conspiracy tag-cult tag-david-cronenberg tag-debbie-harry tag-film-criticism tag-frank-c-carere tag-horror tag-james-woods tag-max-renn tag-media tag-michael-lennick tag-nick-rogers tag-parable tag-rick-baker tag-science-fiction tag-sex tag-snuff-film tag-television tag-tv tag-videodrome tag-videotape tag-violence" itemscope itemtype="http://schema.org/Review">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1 itemprop="itemReviewed">								
                                                Class of 1983: &#8220;Videodrome&#8221;                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="http://www.thefilmyap.com/author/nrogers/"><span itemprop="author">Nick Rogers </span></a></span><span class="date">on <meta itemprop="datePublished" content="February 28, 2013">February 28, 2013</span></div>                                        
                                                                                
                                                                                
                                                                                
                                                                                
                                    </div>
                                    
                                    <div class="details-box-wrapper"><div class="ribbon-wrapper"><div class="ribbon">Details<div class="ribbon-separator">&nbsp;</div></div></div><div class="details-box"><div class="taxonomies-wrapper"></div><div class="details-wrapper"></div></div></div><style type="text/css">.details-box-wrapper {display:none;}</style>                                            
                                                                            
                                    <div class="ratings clearfix"><div class="ratings-panel-wrapper clearfix"><div class="ratings-panel editor-rating"><div class="header"><span class="icon-reviewed"></span>Editor Rating</div><div class="rating-wrapper" id="editor_rating_0"><div class="rating-bar stars-wrapper rating small"><div class="rating-meter">&nbsp;</div><div class="rating-label">Total Yaps</div><div class="rating-value"><div class="stars clearfix"><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-half"></span><span class="icon-star"></span></div></div><br class="clearer" /></div></div><script type="text/javascript">jQuery(window).load(function() {animateRating(-30,1000,"editor_rating_0")});</script><div class="rating-wrapper total" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><div class="rating-bar  stars-wrapper"><div class="rating-label">Yaps</div><meta itemprop="worstRating" content="0"><meta itemprop="ratingValue" content="3.5" /><div class="rating-value"><div class="stars clearfix"><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-half"></span><span class="icon-star"></span></div></div><meta itemprop="bestRating" content="5"><br class="clearer" /></div></div></div></div><div class="ratings-panel-wrapper right clearfix"><div class="ratings-panel user-rating"><div class="header"><div class="hovertorate"><span class="icon-down-bold"></span><span class="hover-text">Hover To Rate</span></div><span class="icon-users"></span>User Rating</div><div id="user_rating_0_wrapper" class="rating-wrapper" onclick = "void(0)"><div id="user_rating_0" class="rating-bar stars-wrapper rating small" data-meta="_total_yaps_user"><div class="rating-meter">&nbsp;</div><div class="rating-label">Total Yaps</div><div class="icon-check"></div><div class="rating-value"><div class="rateit yellow" data-rateit-starwidth="14" data-rateit-starheight="14" data-rateit-resetable="false" data-rateit-value="4" data-rateit-ispreset="true" data-postid="38438" data-rateit-readonly="false" data-meta="_total_yaps_user" data-unlimitedratings=""></div></div><br class="clearer" /><div class="form-selector"></div></div></div><script type="text/javascript">jQuery(window).load(function() {animateRating(-20,1000,"user_rating_0")});</script><div class="rating-wrapper total" data-numratings="1"><div class="rating-bar  stars-wrapper"><div class="rating-label">Yaps</div><div class="rating-number"><span class="value">1</span> rating</div><div class="rating-value"><div class="stars clearfix"><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star"></span></div></div><br class="clearer" /></div></div><div class="rated-legend"><span class="icon-check"></span>You have rated this</div></div></div></div><br class="clearer" />                                    
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><p><strong><em>In the &#8220;Class of &#8230;&#8221; series, Nick Rogers takes a monthly look back at films celebrating either their 20th or 30th anniversary of initial release this year — six from 1993 and six from 1983. The rules: No Oscar nominees and no films among either year&#8217;s top-10 grossers.</em></strong></p>
<p><a href="http://www.thefilmyap.com/?attachment_id=38442" rel="attachment wp-att-38442"><img class="size-full wp-image-38442 alignnone" alt="videodromeinside4" src="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside4.jpg" width="514" height="289" srcset="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside4.jpg 514w, http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside4-300x168.jpg 300w, http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside4-500x281.jpg 500w" sizes="(max-width: 514px) 100vw, 514px" /></a></p>
<p>Many directors discuss the body’s capacity for sex and violence. For more than 40 years, David Cronenberg has dissected it — often quite literally, creating weapons made of human bone or shoving handguns into tremulous, vaginal stomach slits.</p>
<p>Such unpredictably invasive anatomical moments are just one part of Cronenberg’s aggressive tradition. Even in more recent, less fantastical work (<a href="http://www.thefilmyap.com/2010/05/14/heroes-of-the-zeroes-a-history-of-violence/">“A History of Violence”</a> and <a href="http://www.thefilmyap.com/2010/04/05/heroes-of-the-zeroes-eastern-promises/">“Eastern Promises”</a>), he rarely separates sex from violence — poking and prodding to seek potentially perilous similarities in the chemical reactions those acts cause.</p>
<p>In regard to that pursuit, he’s arguably the most fearless filmmaker there is — or, at least, the most fearless one who can usually find funding. He’s also one of the most frustrating.</p>
<p>Cronenberg’s early work often sputtered out his transfixing theses in somewhat self-congratulatory celebrations of how far his gore could go on a limited budget. Then, some of his later films (“Crash” [1996], “eXistenZ,” “Spider”) failed to find the right balance of cerebral and visceral, no matter how controversial the subject.</p>
<p>But Cronenberg couldn’t have achieved his stature without some great films along the way:  “The Dead Zone” (1983), “The Fly” (1986), “Dead Ringers,” “Violence” and “Promises.” Those films strip out his more cartoonish impulses for carnage altogether, their macabre moments more psychologically probing than they are simply wired for shock value. Nor are they without a strong degree of vulnerable humanity, which, in a Cronenberg film, should never <i>ever </i>be confused for sappiness.</p>
<p>As the last before Cronenberg’s trifecta of “Zone” (which this column will visit in September), “Fly” and “Ringers,” 1983’s “Videodrome” falls curiously in the middle.</p>
<p>Certainly, the film would rather stick orgasmically pulsating videotapes between the ribs of its protagonist than craft a cautionary tale that sticks to ribs in the audience. And although it’s stuffed with impressive effects work, “Videodrome’s” third-act rabbit-hole tumble starts to grow a little tiresome.</p>
<p>However, revisiting it 30 years later reveals intriguing and eerily prescient prognostications of many aspects of modern media and technology.</p>
<p><a href="http://www.thefilmyap.com/?attachment_id=38440" rel="attachment wp-att-38440"><img class="alignnone size-full wp-image-38440" alt="videodromeinside2" src="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside2.jpg" width="514" height="289" srcset="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside2.jpg 514w, http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside2-300x168.jpg 300w, http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside2-500x281.jpg 500w" sizes="(max-width: 514px) 100vw, 514px" /></a></p>
<p>Just as Max Renn — the sleazy president of a Canadian TV station played by James Woods — feels compelled to pump up sex and violence to compete with his rivals, so, too, do the heads of U.S. broadcast networks against their cable brethren. Consider this winter’s primetime scene of a woman plunging a knife into her eye on Fox’s “The Following” an attempt to keep up with the sight of sawed-off feet in the current seasons of AMC’s “The Walking Dead” or FX’s “Justified.”</p>
<p>Then there’s Max’s ideological nemesis, stage-named Professor Brian O’Blivion, who communicates only via cassette, the monologue his exclusive method of discourse. After three decades, he’d fit right in on almost any 24-hour “news” network, regardless of its political leanings.</p>
<p>Cronenberg also works in brief digs at corporate malfeasance, religious fundamentalism and American perception of weakness in the Cold War. Plus, there are flickers of two of today’s commonplace media/technology critiques — the <i>schadenfreude</i> that has made reality TV more popular than scripted shows and how 24/7 interconnectivity can erode personal relationships.</p>
<p>“ ‘Videodrome’ has a philosophy, and that’s what makes it dangerous,” one character says of the film’s titular TV program — a pirated snuff-film feed said to emanate from Pittsburgh in which women are physically and sexually abused by hooded tormentors before being killed onscreen.</p>
<p>Oh, but if the <i>movie</i> ultimately shared that same danger of a potent philosophy. Most of the aforementioned metaphors are <i>only </i>teased, given a snippet of a scene before the story moves on. And once “Videodrome” becomes a conspiracy thriller in which “television is reality and reality is less than television,” it never gels into the brain-rattling mind-fuck it thinks it is. Still, this Cronenberg movie remains compulsively watchable even when it gets, well, weird for the sake of weirdness.</p>
<p>Its first act suggests a sturdier film than we ultimately get — an appropriately claustrophobic, scuzzy setup. (Retrospective essays reveal it was as much a function of budget as directorial intent; many scenes were filmed within one large building.)</p>
<p>Max’s channel is programmed with a cornucopia of cheesecake pornography — including a Japanese program that opens with wooden-dildo masturbation. But that soft-core stuff barely gets the brain’s sine waves going any longer. That’s why Max takes an interest in “Videodrome” when he sets his grubby eyes on a bootleg feed.</p>
<p>If ever a role was tailor-made for Woods, it’s Max. This leather tie-wearing cretin becomes Cronenberg’s mouthpiece for shrewd observations about desensitization and brazenly describes “Videodrome” as though it were a stock option: “Just torture and murder. No plot. No characters. Very realistic. I think it’s what’s next.”</p>
<p><a href="http://www.thefilmyap.com/?attachment_id=38441" rel="attachment wp-att-38441"><img class="alignnone size-full wp-image-38441" alt="videodromeinside3" src="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside3.jpg" width="514" height="276" srcset="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside3.jpg 514w, http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside3-300x161.jpg 300w, http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside3-500x268.jpg 500w" sizes="(max-width: 514px) 100vw, 514px" /></a></p>
<p>Max also smugly defends himself on the news by saying his network provides “a harmless outlet for fantasies and frustration” before turning it into an opportunity to get radio DJ Nicki Brand (Blondie lead singer Debbie Harry) in the sack.</p>
<p>He does, but only after she insists watching “Videodrome” will get her stimulated. There’s then post-coital scene in which Max pierces Nicki ear in a close-up that speaks to cultural rituals. Maybe ours is overstimulation, Cronenberg seems to say, but then the story starts to spin sideways.</p>
<p><a href="http://www.thefilmyap.com/?attachment_id=38439" rel="attachment wp-att-38439"><img class="alignnone size-full wp-image-38439" alt="videodromeinside1" src="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside1.jpg" width="514" height="279" srcset="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside1.jpg 514w, http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside1-300x162.jpg 300w, http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside1-500x271.jpg 500w" sizes="(max-width: 514px) 100vw, 514px" /></a></p>
<p>Save those early moments, though, Max is the rare Woods character suffocated by the story surrounding him. And the actor spends the final 30 minutes in a numb, flat-affect stupor, a brainwashed assassin for two opposing factions who would seek to control the “Videodrome” program. (The program, we learn, is actually a hallucination-inducing, tumor-causing signal that, if globally broadcast, will weed out the depraved who would watch it incessantly.)</p>
<p>Although it comes to overwhelm the film’s narrative, “Videodrome’s” effects work does provide some indelible, striking images.</p>
<p>In a film filled with hallucinatory moments, the most surreally unforgettable is a collaboration between special video effects man Michael Lennick and special effects director Frank C. Carere. Nicki appears to Max on his console TV, the top of which becomes an undulating, membranous erotic zone that responds to his touch. As Nikki’s lips fill the TV frame, a convex curve leaps off the screen and envelops Max.</p>
<p><iframe width="514" height="315" src="http://www.youtube.com/embed/8IxeroqZSuo?rel=0" frameborder="0" allowfullscreen></iframe></p>
<p>Videotapes also feel convincingly alive, quivering like stimulated G-spots. And makeup guru Rick Baker — a year after winning the inaugural Oscar for Best Makeup and Hairstyling (his first of seven) — fuses a gun to bone and flesh in a scene as persuasive as “An American Werewolf in London’s” canine transformation.</p>
<p><a href="http://www.thefilmyap.com/?attachment_id=38443" rel="attachment wp-att-38443"><img class="alignnone size-full wp-image-38443" alt="videodromeinside5" src="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside5.jpg" width="514" height="276" srcset="http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside5.jpg 514w, http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside5-300x161.jpg 300w, http://www.thefilmyap.com/wp-content/uploads/2013/02/videodromeinside5-500x268.jpg 500w" sizes="(max-width: 514px) 100vw, 514px" /></a></p>
<p>But to what end is the ick for? Only the moments involving Max’s gun, embedded earlier in his stomach, potently speak to any sort of theme — how vengeance is in our veins or how we consume, digest, process and expel violence in our daily diet. Again, those are fleeting moments in scenes that exist to emphasize “Videodrome’s” prosthetics more than they do its scattershot psychological viewpoint.</p>
<p>(If a proposed “Videodrome” remake ever happens, it will, if it’s remotely smart, tackle the increasingly loud debate of entertainment’s effects on individual acts of violence. Or, it will just have Colin Farrell in the lead and call it a day.)</p>
<p>Taken on the terms of the films he’s made, Cronenberg’s fetishistic fascination with flesh has been for better or for worse. Earlier works like “Videodrome” show that sometimes, he’s a provocateur only to a point — boldly striding past boundaries of comfort but getting the heebie-jeebies upon approaching true profundity. But it also shows he wasn’t too far from figuring out which incisions could cut the deepest.</p>
<p><iframe width="514" height="315" src="http://www.youtube.com/embed/UFHey3utk0I?rel=0" frameborder="0" allowfullscreen></iframe></p>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ --><h3>Comments</h3><p><fb:comments-count href=http://www.thefilmyap.com/movies/class-of-1983-videodrome/></fb:comments-count> comments</p><div class="fb-comments" data-href="http://www.thefilmyap.com/movies/class-of-1983-videodrome/" data-numposts="5" data-width="100%" data-colorscheme="light"></div></div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><a class="like-button do-like 38438 info-bottom" data-postid="38438" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">0 likes</span></a><div class="category-list"><span class="icon-category"></span><a href="http://www.thefilmyap.com/topics/features/commentary/" title="View all posts in Commentary">Commentary</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="http://www.thefilmyap.com/tag/1983/" title="1983 Tag" class="1983">1983</a><a href="http://www.thefilmyap.com/tag/canada/" title="Canada Tag" class="canada">Canada</a><a href="http://www.thefilmyap.com/tag/class-of-1983/" title="Class of 1983 Tag" class="class-of-1983">Class of 1983</a><a href="http://www.thefilmyap.com/tag/conspiracy/" title="conspiracy Tag" class="conspiracy">conspiracy</a><a href="http://www.thefilmyap.com/tag/cult/" title="cult Tag" class="cult">cult</a><a href="http://www.thefilmyap.com/tag/david-cronenberg/" title="David Cronenberg Tag" class="david-cronenberg">David Cronenberg</a><a href="http://www.thefilmyap.com/tag/debbie-harry/" title="Debbie Harry Tag" class="debbie-harry">Debbie Harry</a><a href="http://www.thefilmyap.com/tag/film-criticism/" title="film criticism Tag" class="film-criticism">film criticism</a><a href="http://www.thefilmyap.com/tag/frank-c-carere/" title="Frank C. Carere Tag" class="frank-c-carere">Frank C. Carere</a><a href="http://www.thefilmyap.com/tag/horror/" title="Horror Tag" class="horror">Horror</a><a href="http://www.thefilmyap.com/tag/james-woods/" title="James Woods Tag" class="james-woods">James Woods</a><a href="http://www.thefilmyap.com/tag/max-renn/" title="Max Renn Tag" class="max-renn">Max Renn</a><a href="http://www.thefilmyap.com/tag/media/" title="media Tag" class="media">media</a><a href="http://www.thefilmyap.com/tag/michael-lennick/" title="Michael Lennick Tag" class="michael-lennick">Michael Lennick</a><a href="http://www.thefilmyap.com/tag/nick-rogers/" title="nick rogers Tag" class="nick-rogers">nick rogers</a><a href="http://www.thefilmyap.com/tag/parable/" title="parable Tag" class="parable">parable</a><a href="http://www.thefilmyap.com/tag/rick-baker/" title="Rick Baker Tag" class="rick-baker">Rick Baker</a><a href="http://www.thefilmyap.com/tag/science-fiction/" title="science fiction Tag" class="science-fiction">science fiction</a><a href="http://www.thefilmyap.com/tag/sex/" title="sex Tag" class="sex">sex</a><a href="http://www.thefilmyap.com/tag/snuff-film/" title="snuff film Tag" class="snuff-film">snuff film</a><a href="http://www.thefilmyap.com/tag/television/" title="Television Tag" class="television">Television</a><a href="http://www.thefilmyap.com/tag/tv/" title="TV Tag" class="tv">TV</a><a href="http://www.thefilmyap.com/tag/videodrome/" title="Videodrome Tag" class="videodrome">Videodrome</a><a href="http://www.thefilmyap.com/tag/videotape/" title="videotape Tag" class="videotape">videotape</a><a href="http://www.thefilmyap.com/tag/violence/" title="violence Tag" class="violence">violence</a><br class="clearer" /></div></div><br class="clearer" /></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>More Goodness<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="7093" data-method="tags" class="info active" title="More articles tagged: 1983">1983<span class="bottom-arrow"></span></a><a data-sorter="6867" data-method="tags" class="info" title="More articles tagged: Canada">Canada<span class="bottom-arrow"></span></a><a data-sorter="16209" data-method="tags" class="info" title="More articles tagged: Class of 1983">Class of 1983<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="http://www.thefilmyap.com/movies/class-of-1983-scarface/"><img width="35" height="23" src="http://www.thefilmyap.com/wp-content/uploads/2013/12/scarfaceinside1.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Class of 1983: &#8220;Scarface&#8221;" srcset="http://www.thefilmyap.com/wp-content/uploads/2013/12/scarfaceinside1.jpg 514w, http://www.thefilmyap.com/wp-content/uploads/2013/12/scarfaceinside1-300x197.jpg 300w, http://www.thefilmyap.com/wp-content/uploads/2013/12/scarfaceinside1-456x300.jpg 456w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="http://www.thefilmyap.com/movies/class-of-1983-scarface/">Class of 1983: &#8220;Scarface&#8221;</a></div><a class="hover-link" href="http://www.thefilmyap.com/movies/class-of-1983-scarface/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="http://www.thefilmyap.com/movies/class-of-1983-something-wicked-this-way-comes/"><img width="35" height="24" src="http://www.thefilmyap.com/wp-content/uploads/2013/10/somethingwickedthiswaycomesinside1.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Class of 1983: &#8220;Something Wicked This Way Comes&#8221;" srcset="http://www.thefilmyap.com/wp-content/uploads/2013/10/somethingwickedthiswaycomesinside1.jpg 514w, http://www.thefilmyap.com/wp-content/uploads/2013/10/somethingwickedthiswaycomesinside1-300x203.jpg 300w, http://www.thefilmyap.com/wp-content/uploads/2013/10/somethingwickedthiswaycomesinside1-443x300.jpg 443w, http://www.thefilmyap.com/wp-content/uploads/2013/10/somethingwickedthiswaycomesinside1-200x135.jpg 200w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="http://www.thefilmyap.com/movies/class-of-1983-something-wicked-this-way-comes/">Class of 1983: &#8220;Something Wicked This Way Comes&#8221;</a></div><a class="hover-link" href="http://www.thefilmyap.com/movies/class-of-1983-something-wicked-this-way-comes/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="http://www.thefilmyap.com/movies/class-of-1983-the-dead-zone/"><img width="35" height="21" src="http://www.thefilmyap.com/wp-content/uploads/2013/09/deadzoneinside3.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Class of 1983: &#8220;The Dead Zone&#8221;" srcset="http://www.thefilmyap.com/wp-content/uploads/2013/09/deadzoneinside3.jpg 514w, http://www.thefilmyap.com/wp-content/uploads/2013/09/deadzoneinside3-300x179.jpg 300w, http://www.thefilmyap.com/wp-content/uploads/2013/09/deadzoneinside3-500x300.jpg 500w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="http://www.thefilmyap.com/movies/class-of-1983-the-dead-zone/">Class of 1983: &#8220;The Dead Zone&#8221;</a></div><a class="hover-link" href="http://www.thefilmyap.com/movies/class-of-1983-the-dead-zone/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="http://www.thefilmyap.com/movies/class-of-1983-twilight-zone-the-movie/"><img width="35" height="20" src="http://www.thefilmyap.com/wp-content/uploads/2013/08/twilightzoneinside2.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Class of 1983: &#8220;Twilight Zone: The Movie&#8221;" srcset="http://www.thefilmyap.com/wp-content/uploads/2013/08/twilightzoneinside2.jpg 514w, http://www.thefilmyap.com/wp-content/uploads/2013/08/twilightzoneinside2-300x169.jpg 300w, http://www.thefilmyap.com/wp-content/uploads/2013/08/twilightzoneinside2-500x282.jpg 500w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="http://www.thefilmyap.com/movies/class-of-1983-twilight-zone-the-movie/">Class of 1983: &#8220;Twilight Zone: The Movie&#8221;</a></div><a class="hover-link" href="http://www.thefilmyap.com/movies/class-of-1983-twilight-zone-the-movie/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="http://www.thefilmyap.com/movies/class-of-1983-the-outsiders/"><img width="35" height="27" src="http://www.thefilmyap.com/wp-content/uploads/2009/09/SChool-movies-Outsiders.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Class of 1983: &#8220;The Outsiders&#8221;" srcset="http://www.thefilmyap.com/wp-content/uploads/2009/09/SChool-movies-Outsiders.jpg 531w, http://www.thefilmyap.com/wp-content/uploads/2009/09/SChool-movies-Outsiders-300x232.jpg 300w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="http://www.thefilmyap.com/movies/class-of-1983-the-outsiders/">Class of 1983: &#8220;The Outsiders&#8221;</a></div><a class="hover-link" href="http://www.thefilmyap.com/movies/class-of-1983-the-outsiders/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="http://www.thefilmyap.com/movies/you-only-live-twenty-thrice-octopussy/"><img width="35" height="19" src="http://www.thefilmyap.com/wp-content/uploads/2012/08/octopussyinside9.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="You Only Live Twenty-Thrice: &#8220;Octopussy&#8221;" srcset="http://www.thefilmyap.com/wp-content/uploads/2012/08/octopussyinside9.jpg 514w, http://www.thefilmyap.com/wp-content/uploads/2012/08/octopussyinside9-300x166.jpg 300w, http://www.thefilmyap.com/wp-content/uploads/2012/08/octopussyinside9-500x278.jpg 500w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="http://www.thefilmyap.com/movies/you-only-live-twenty-thrice-octopussy/">You Only Live Twenty-Thrice: &#8220;Octopussy&#8221;</a></div><a class="hover-link" href="http://www.thefilmyap.com/movies/you-only-live-twenty-thrice-octopussy/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-10" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Articles</h3>
                
                                
            </div>        <div class="post-list overlays clearfix"><div class="box-panel box-1"><div class="box-image" style="background-image:url(http://www.thefilmyap.com/wp-content/uploads/The-Space-Between-Us-featured-349x240.jpg);"></div><a class="box-link" href="http://www.thefilmyap.com/movies/the-space-between-us/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  stars_wrapper"><div class="editor_rating solo"><div class="stars clearfix"><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star"></span><span class="icon-star"></span><span class="icon-star"></span></div></div></div><div class="article-info">The Space Between Us</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(http://www.thefilmyap.com/wp-content/uploads/fiftyshadesdarkerfeaturedimage11217-349x240.jpg);"></div><a class="box-link" href="http://www.thefilmyap.com/movies/contests-fifty-shades-darker-indianapolis/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">CONTESTS: FIFTY SHADES DARKER (INDIANAPOLIS)</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(http://www.thefilmyap.com/wp-content/uploads/RaisingArizonaLede-349x240.jpg);"></div><a class="box-link" href="http://www.thefilmyap.com/movies/class-of-2017-raising-arizona/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  stars_wrapper"><div class="editor_rating solo"><div class="stars clearfix"><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-full"></span></div></div></div><div class="article-info">Class of 1987: &#8216;Raising Arizona&#8217;</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(http://www.thefilmyap.com/wp-content/uploads/Barbarella-featured-349x240.jpg);"></div><a class="box-link" href="http://www.thefilmyap.com/movies/barbarella-1968/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  stars_wrapper"><div class="editor_rating solo"><div class="stars clearfix"><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star"></span><span class="icon-star"></span><span class="icon-star"></span></div></div></div><div class="article-info">Barbarella (1968)</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(http://www.thefilmyap.com/wp-content/uploads/A-Dogs-Purpose-featured-349x240.jpg);"></div><a class="box-link" href="http://www.thefilmyap.com/movies/split-still-reigns-dog-overcomes-controversy-for-strong-opening/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">&#8220;Split&#8221; still reigns; &#8220;Dog&#8221; overcomes controversy for strong opening</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(http://www.thefilmyap.com/wp-content/uploads/Reacher2Lede-349x240.jpg);"></div><a class="box-link" href="http://www.thefilmyap.com/movies/jack-reacher-never-go-back-2/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  stars_wrapper"><div class="editor_rating solo"><div class="stars clearfix"><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star"></span></div></div></div><div class="article-info">Jack Reacher: Never Go Back</div></div></div></div><div class="box-panel box-7"><div class="box-image" style="background-image:url(http://www.thefilmyap.com/wp-content/uploads/the-founder-349x240.jpg);"></div><a class="box-link" href="http://www.thefilmyap.com/movies/the-founder/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  stars_wrapper"><div class="editor_rating solo"><div class="stars clearfix"><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star-half"></span><span class="icon-star"></span><span class="icon-star"></span></div></div></div><div class="article-info">The Founder</div></div></div></div><div class="box-panel box-8"><div class="box-image" style="background-image:url(http://www.thefilmyap.com/wp-content/uploads/resident-evil-the-final-chapter-349x240.jpg);"></div><a class="box-link" href="http://www.thefilmyap.com/movies/63617/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  stars_wrapper"><div class="editor_rating solo"><div class="stars clearfix"><span class="icon-star-full"></span><span class="icon-star-full"></span><span class="icon-star"></span><span class="icon-star"></span><span class="icon-star"></span></div></div></div><div class="article-info">Resident Evil: The Final Chapter</div></div></div></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>




	
</div> 


    <div id="subfooter-wrapper" class="solo">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            Copyright &copy; 2017 THE FILM YAP,&nbsp;All Rights Reserved.                        
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="http://www.thefilmyap.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="http://www.thefilmyap.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

	<div style="display:none">
	</div>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201705'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-admin/js/iris.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.thefilmyap.com/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=1674882656065160&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<script type='text/javascript' src='http://stats.wp.com/e-201705.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.4.2',blog:'41506135',post:'38438',tz:'-5',srv:'www.thefilmyap.com'} ]);
	_stq.push([ 'clickTrackerInit', '41506135', '38438' ]);
</script>

</body>

</html>
